TS3MusicBot startet einfach nicht

  • Wenn ich apt-get install openjdk-7-jre anführen will kommt das


    root@vps:~# apt-get install openjdk-7-jre
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    openjdk-7-jre : Depends: openjdk-7-jre-headless (= 7u79-2.5.5-1~deb7u1)
    Depends: libasound2 (>= 1.0.16)
    Depends: libatk1.0-0 (>= 1.12.4) but it is not going to be installed
    Depends: libcairo2 (>= 1.2.4) but it is not going to be installed
    Depends: libgdk-pixbuf2.0-0 (>= 2.22.0) but it is not going to be installed
    Depends: libgif4 (>= 4.1.4) but it is not going to be installed
    Depends: libgtk2.0-0 (>= 2.8.0) but it is not going to be installed
    Depends: libpango1.0-0 (>= 1.14.0) but it is not going to be installed
    Depends: libxext6 but it is not going to be installed
    Depends: libxi6 but it is not going to be installed
    Depends: libxrender1 but it is not going to be installed
    Depends: libxtst6 but it is not going to be installed
    Depends: libxrandr2 but it is not going to be installed
    Depends: libxinerama1 but it is not going to be installed
    Depends: libgl1-mesa-glx but it is not going to be installed or
    libgl1
    Depends: libatk-wrapper-java-jni (>= 0.30.4-0ubuntu2) but it is not going to be installed
    Recommends: libgnome2-0 but it is not going to be installed
    Recommends: libgnomevfs2-0 but it is not going to be installed
    Recommends: libgconf2-4 but it is not going to be installed
    oracle-java7-set-default : Depends: oracle-java7-installer but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    root@vps:~#

  • ok ist gemacht


    root@vps:~# java -version
    java version "1.7.0_80"
    Java(TM) SE Runtime Environment (build 1.7.0_80-b15)
    Java HotSpot(TM) 64-Bit Server VM (build 24.80-b11, mixed mode)
    root@vps:~#

  • Also wir nutzen diesen Startbefehl

    cd system
    java -Xms50m -Xmx50m -XX:+DisableAttachMechanism -jar TS3MusicBotLauncher.jar -secretkey ${1} -account ${2} -port ${3} -webif-pw ${4}
    cd ..

    Kundennummer: 10088

  • @


    <a class="" href="http://teklab.de/support/user/1937-k%C3%BChnellan4play/" title="">Kühnel@Lan4Play</a>



    Bei mir geht das nicht.


    Quote from GenXRoad

    Okay :)



    Aber wenn du nun java drauf hast sollte es eigentlich funktionieren



    Java ist drauf lässt sich aber über teklab nicht starten




  • Wenn ich das mache kommt das bei raus

    Autoupdater: Found a newer TS3MusicBot version.
    Updating now ...
    [Progress] 100.00%
    Failed to load : null
    java.lang.reflect.InvocationTargetException
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at ts3musicbotlauncher.TS3MusicBotLauncher.main(TS3MusicBotLauncher.java:324)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
    at java.lang.reflect.Method.invoke(Method.java:606)
    at JavaPreloader.run(JavaPreloader.java:244)
    at JavaPreloader.runPreloader(JavaPreloader.java:509)
    at JavaPreloader.main(JavaPreloader.java:494)
    Caused by: java.awt.HeadlessException:
    No X11 DISPLAY variable was set, but this program performed an operation which requires it.
    at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:207)
    at java.awt.Window.<init>(Window.java:535)
    at java.awt.Frame.<init>(Frame.java:420)
    at java.awt.Frame.<init>(Frame.java:385)
    at javax.swing.SwingUtilities$SharedOwnerFrame.<init>(SwingUtilities.java:1757)
    at javax.swing.SwingUtilities.getSharedOwnerFrame(SwingUtilities.java:1832)
    at javax.swing.JOptionPane.getRootFrame(JOptionPane.java:1697)
    at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:863)
    at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:667)
    at javax.swing.JOptionPane.showMessageDialog(JOptionPane.java:638)
    at JavaPreloader.error(JavaPreloader.java:1282)
    at JavaPreloader.runPreloader(JavaPreloader.java:513)
    at JavaPreloader.main(JavaPreloader.java:494)
    ... 12 more
    Bestimmt immer noch Problem mit java

  • Hallo

    Ok Musicbot habe ich hin bekommen läuft auch nur ich habe denn jetzt auf denn Server 5.230.156.17X der Bot soll aber auf denn Ts 5.230.156.15X zugreifen wie stell eich das ein ? denn wenn ich unter bei Einstellung in teklab die TS IP und Port änder der Server nicht mehr online.



    -close-