Posts by Finest

16.03.2020: Due to the current events regarding the Cornavirus Pandemic, teklab.de offers a 30% discount with the discount code "STAYATHOME" until further notice. Insert this code at the end of the order.

    Schaut mal /home/skripte/restart -> dort dann nach einem Reboot per Bash Skript die Dateien per While oder For auflisten und ausführen.




    Hallo,


    das was du mir hier schreibst ist ja ein linux verzeichnis!


    dieses ist leer beim linux root! weil ich habe ja auch einen solchen angebunden.




    wie gesagt geht um windows. der server stürzt ab und dan steht er ja in der datenbank torztdem noch als online also online = 1




    Tabelle teklab_gameserver spalte online ist wenn der server läuft auf 1 auch wenn der server abgestützt ist :D




    somit dächt ich mir wou wäre doch ganz einfach wenn ein tool überprüft ok qstats i offline also server pingt nicht


    jedoch sollte er on sein weil in der datenbank steht er ja auf 1 dan start ich ihn mal




    so wäre mein grundgedanke :D




    es handelt sich um einen arma 2 server auf windows. das funzt alles 1a server statet funzt auch mit pid usw.




    aber die leute benutzen hald ein restarttool das den server alle 5 stunden mit #shutdown runter fährt jetzt wäre es hald geil wenn der wieder starten würde :D

    // push




    weiss keiner ein lösung es wäre sehr wichtig :/




    für mein restart script




    oder gäbe es die möglichkeit ich würde mit goto arbeiten.




    das er die parameter die vom webinterface übertragen werden im goto zum anfang der bat wieder mit übertragen werden




    also z.b.




    set arg1 = %1


    set arg2 = %2




    STARTSCRIPT -port=%arg1% ip=%arg2%




    so jetzt schmiert der server ab und startet neu




    ich mach




    timeout 10


    goto ANFANG




    dan müsste er jetzt bei goto die parameter von arg1 und 2 wieder mit übernehmen


    wäre das möglich ?

    ich hätte hierzu noch eine frage!


    ich will ein script für ein anderes spiel verwenden!







    wo definiere ich das %1 bzw woher bezieht deine bat datei die spieleranzahl aus dem webinterface ?




    weil bei der config.cfg werden die spieleranzahlen quasi in der config.cfg geregelt somit muss ich eine sperre einbauen das diese nicht verändert werden kann!

    Hi ich schließe mich hier mal an!


    ich habe es mit der my_start.bat und my_stop.bat probiert!


    er nimmt mir diese datei nicht !




    wenn ich auf restart klicke passiert nix


    wenn ich die bat datein rausnehme aus dem ordner startet der server normal

    A ok :D dan werd ich wohl die addon mod funktion machen mit update 1 - 5


    nach 5 ein masterupdate erstezen und wieder bei 1 anfangen oder so :D




    das ist denke ich mal das einfachste

    Hallo,


    ich nochmal :D




    und zwar habe ich das problem das mir das Webinterface




    Server offline


    anzeigt obwohl der gameserver definitiv am windows root läuft :D




    hat da wer ne idee wie ich die anzeuge gangbar mache?


    es handelt sich um ein von mir angelegtes game er startet es mit port usw alles richtig über hlsw krieg ich den server mit IP:Port super angezeigt.






    Hallo,


    wie das thema schon sagt hätte ich gerne mal ein paar ratschläge :D




    das vorgeschlagen updatescript


    wget gsimageserverone/css_update.tar;tar -xf css_update.tar;rm css_update.tar


    leuchtet mir ja ein :D




    jedoch müsste ich jetzt wget.exe in jedem spielverzeichnis installiert haben dan läd er mir das runter dan müsste ich es mit einer unzip datei entpacken lassen und und und ist sehr kompliziert ... für ein simplen update!




    gibt es eine einfachere lösung ?




    ich hätte jetzt einfach addons erstellt mit update 1 2 usw und die kunden das installieren lassen


    Hallo COmmunity,




    ich bräuchte mal ein bischen hilfe und zwar möchte ich für meine Armaserver eine Easyconfig erstelle!


    jedoch gibt es da ein paar sachen die ich so nicht hinbekomme!




    Beispiel wie der einträg später aussehen muss!


    hostname = "DayZ MAP/MODNAME [MAP/MOD VERSION] [UTC -2] [REGULAR|3DP:ON|CH:ON] hosted by dayzforum.net";




    {%TSTART%}Servername{%TD%}hostname{%TD%} = {%TD%}yes{%TD%}input{%TD%}300{%TD%}DayZ MAP/MODNAME [MAP/MOD VERSION] [UTC -2] [REGULAR|3DP:ON|CH:ON] hosted by dayzforum.net{%TD%} {%TD%}


    g{%TEND%}




    jedoch bekomme ich es nun nicht hin das er mir das erstens in " setzt und zweitens er am schluss das ; macht




    arma braucht diese zeichenfolge sonst funktioniert die config nicht.


    ich möchte jedoch auch nicht das mein kunde immer das ""; angeben muss weil das ist eine eindeutige fehlerquelle!




    wäre cool wen da jemand ne idee hat :D




    Desweiteren muss in der server.cfg der eintrag maxplayers gesetzt werden




    d.h. jeder meiner kunden könnte sich die server slots setzten wie er will (kann bei arma nicht über startparameter) geregelt werden.




    wie kann ich es nun machen das er mir diesen wert




    maxPlayers = 40;


    automatisch auf die slotzahl die ich im gameserver eingestellt habe setzt :D




    danke schon mal für die hilfe :D

    http://teklab.de/wiki/lexicon/…yz/index.html?s=teklab.de




    Hier wird das Installieren mit Linux erklärt, leider ist Arma/Dayz aber ein Windowsbasierendes Spiel, ich habe aktuell mit den Startbefehlen Probleme und würde mich freuen wenn mir wer helfen könnte.




    Startbefehl:


    Expansion/beta/arma2oaserver_lostray.exe -port=2902 -mod=@DayZOvaron;@reality_1.ovaron -name=Reality -config=dayz_1.ovaron\ServerSettings.cfg -cfg=dayz_1.ovaron\basic.cfg -profiles=dayz_1.ovaron




    der server startet zwar aber ohne servername er ignoriert die \ und löscht mir das zeichen nach dem abspeichern auch raus.


    ich habe es auch bereits mit einen / probiert erkennt er nicht es ist also nötig den \ zu nehmen.


    Ich habe es mit "\" probiert '\' usw hat da noch wer nen tipp ?




    Bzw hat wer die Versprochenen files :D für dayz die als spiel angeboten werden :D