Paysafecard in Tekbase

  • Hallo Centro.

    1. Dazu solltest du bereits die neuste Version von TekBASE (7.3.7 oder höher) nutzen, falls noch nicht geupdated dann am besten nachholen oder diesen Schritt ignorieren sofern schon gemacht.
    2. In den Ordner /includes/api/payment/paysafecard wechseln.
    3. Die Datei paysafe.php öffnen und Zeile 23 (shopurl), 37 (username), 38 (passwort) hinzufügen.
    4. Zeile 40 > $foo = new PaySafe; LÖSCHEN
    5. WICHTIG: Deine Webserver-IP wo dein TekBASE drauf läuft muss von Paysafecard.com gewhitelisted werden.
    6. Weiteres in der Datei /includes/api/payment/ > paysafecard_infos.txt

    Alles verstanden? Falls nicht fragen ;)

  • Hallo,

    also im Ordner includes/api/payment liegt die Datei "paysafe.php" ist das so richtig? Bei mir existiert /includes/api/payment/paysafecard nicht :(

  • Siehe Schritt 1 > TekBASE 7.3.7 oder höher nutzen. Ansonsten das Update 7307.zip runterladen und NUR den Ordner paysafecard hinzufügen.

  • Möglich weil der Updater die UpdateZIP nicht runterlädt und entpackt, daher siehe Changelog dort steht das man es manuell machen soll.

  • Also ich habe jetzt den Ordner, ich habe jetzt NAME und PASSWORT eingetragen, muss ich bei shopurl meine URL eintragen oder die von PaySafecard?

  • Quote from Centro

    Also ich habe jetzt den Ordner, ich habe jetzt NAME und PASSWORT eingetragen, muss ich bei shopurl meine URL eintragen oder die von PaySafecard?


    Okay ich war mal wieder zu schnell :) es steht ja alles in den Informationen

  • hallo habe auch ein problem ich habe alles so gemacht wie es da steht aber bei mir kommt eine weiße seite weiß nicht warum kann da einer helfe bitte danke MfG

  • Quote from luiluiboy014

    hallo habe auch ein<a class="" href="#96973406" title="Click to Continue > by PhraseProfessor"> problem</a> ich habe alles so gemacht wie es da steht aber bei mir kommt eine weiße seite weiß nicht warum kann da einer helfe bitte danke MfG



    Lese doch einmal bitte einfach die Logs durch, Ist das so Schwer ?....

  • Also bei mir kommt nur das

    Code
    1. [Mon Aug 10 18:30:52 2015] [warn] [client 109.90.61.175] mod_fcgid: stderr: PHP Notice: Undefined index: shop in /var/www/vhosts/Speed-Hosting4you.de/httpdocs/includes/api/payment/paysafecard/paysafe.php on line 6, referer: https://speed-hosting4you.de/members.php?op=membersBillPay&typ=10&money=10
    2. [Mon Aug 10 18:30:52 2015] [warn] [client 109.90.61.175] mod_fcgid: stderr: PHP Fatal error: SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://soa.paysafecard.com/psc/services/PscService?wsdl' : failed to load external entity "https://soa.paysafecard.com/psc/services/PscService?wsdl", referer: https://speed-hosting4you.de/members.php?op=membersBillPay&typ=10&money=10
    3. [Mon Aug 10 18:30:52 2015] [warn] [client 109.90.61.175] mod_fcgid: stderr: in /var/www/vhosts/Speed-Hosting4you.de/httpdocs/includes/api/payment/paysafecard/api.class.php on line 791, referer: https://speed-hosting4you.de/members.php?op=membersBillPay&typ=10&money=10
    4. [Mon Aug 10 18:30:52 2015] [warn] [client 109.90.61.175] mod_fcgid: stderr: PHP Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-ERROR: Parsing WSDL: Couldn't load from 'https://soa.paysafecard.com/psc/services/PscService?wsdl' : failed to load external entity "https://soa.paysafecard.com/psc/services/PscService?wsdl", referer: https://speed-hosting4you.de/members.php?op=membersBillPay&typ=10&money=10
  • Du bist im Live modus, musst aber in den Test Modus. Deine IP ist nur für den Test Modus freigeschaltet, bis die paysafecard tests durchgelaufen sind.

    Das kannst du in Zeile 53 in der paysafe.php einstellen