Ioncube Update

16.03.2020: Due to the current events regarding the Cornavirus Pandemic, teklab.de offers a 30% discount with the discount code "STAYATHOME" until further notice. Insert this code at the end of the order.
  • Hallo,
    ich habe versucht meinen Ioncube Loader zu updaten, aber wenn ich in der php.ini einstelle das die ioncube_loader_lin_5.6.so genutzt werden soll bekomme ich folgende fehlermeldung;

    Code
    Site error: the file /var/www/vhosts/meinedomain.de/httpdocs/index.php requires the ionCube PHP Loader ioncube_loader_lin_5.3.so to be installed by the website operator. If you are the website operator please use the ionCube Loader Wizard to assist with installation.


    Als Verwaltungsoberfläche nutze ich Plesk und als Betriebssystem: Ubuntu 12.04
    Mache ich etwas falsch ?

  • Ioncube ist scheisse geregelt das die dateien nur ioncube_loader_lin_5.x.so heissen man daran aber nicht erkennt welche ioncube version verwendet wird, evtl kann ja CF im admin eine abfrage der Version integrieren + Abfrage aktuelle Version bei ioncube¿

  • Quote from GSXH.de

    Steht doch da. Du brauchst die 5.3er-Datei. Nicht die für 5.6.

    Lesen sollte man schon können...



    Ich kann lesen, aber ich will ioncube ja von 5.3 auf 5.6 updaten. Deshalb kommt ja der fehler.

  • ERROR!

    lin_5.3 <- PHP 5.3 nicht der LOADER!
    lin_5.6 <- PHP 5.6 nicht der LOADER!


    du musst die ioncube_loader_lin_5.3.so einbinden aus dem aktuellstem Download der auf ioncube.com zum download bereit steht

    dann klappt auch alles die ioncube Version ist: 4.7.3


    http://www.ioncube.com/loaders.php <- da downloaden und die Datei passend zu deiner PHP Version einbinden (php -v) auf Console und du weisst deine Version dann